English When CS2D support Lua engine 5.3.0?

13 replies
Goto Page
To the start Previous 1 Next To the start
Up
TobyInChina
User
Offline Off
Lua engine 5.3.0 support UTF-8 and add many new functions
@user DC: please consider update new Lua Engline!

http://www.lua.org/manual/5.3/readme.html
CS2D Chinese Station(CS2DCN) Founder。Chinese language translation submitter!As you see,We are the second largest player group of CS2D! | Our Discord
05.10.19 03:37:54 pm
Up
Ya_bo
User
Offline Off
I agree.
Bruuuuuuh
05.10.19 03:45:27 pm
Up
DC
Admin
Offline Off
Answer to the thread title: Never. Sorry.

Last time I messed with Lua (Lua JIT stuff) everything exploded. I really do not want to touch the Lua version. So an upgrade to 5.3. is extremely unlikely.

Background info: I would need a BlitzMax module for Lua 5.3.0 which is compatible with the current Lua BlitzMax module CS2D is using (PUB.Lua). As far as I know there is no such thing (BlitzMax is dead and not updated anymore) and I'm not willing to invest time to upgrade it on my own (it's an EXTREMELY annoying task).
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
05.10.19 03:59:20 pm
Up
Gaios
Security Supporter
Offline Off
We can use UTF-8 in CS2D as well.
05.10.19 04:27:37 pm
Up
TobyInChina
User
Offline Off
@user Gaios:
Engineer ‘s utf-8 Lua have some big Bug and hook:say dont support chinese,
I think if CS2D support UTF-8 completely,It's will not have this trouble.
Lua 5.2 support utf-8,so I think it's a good way!
CS2D Chinese Station(CS2DCN) Founder。Chinese language translation submitter!As you see,We are the second largest player group of CS2D! | Our Discord
16.05.22 05:08:45 pm
Up
jutyprince
User
Offline Off
Need bit operations and new metamethods.
16.05.22 05:23:11 pm
Up
Salad Fingers
Super User
Offline Off
Replying 3-year-old threads for the win. Either way won't happen.
CS2DArchive - Version Database www.CS2DArchive.com - WebHosting: www.BroHosting.eu
16.05.22 05:34:51 pm
Up
jutyprince
User
Offline Off
user DC: stated a lot of times that he doesn't want CS2D game on Steam. But now the game is on the Steam platform. What do you say to that?
16.05.22 05:50:16 pm
Up
Kolia_rus
GAME BANNED
Offline Off
user Salad Fingers has written:
Replying 3-year-old threads for the win. Either way won't happen.


This is a dilemma of all forums - "what's better, to necropost or to create a duplicate thread?"
You received a game ban because you seem to be a cheater. You are not able to log-in in-game anymore.
16.05.22 08:30:12 pm
Up
DC
Admin
Offline Off
Necro posting is better.

A Lua engine upgrade still won't happen.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
18.05.22 06:14:12 pm
Up
UrNightmare
User
Offline Off
Upgrading to Lua 5.3 is useless, it just minor update. And also it will breaks the game's code, like shooting, spectating, EVEN script function wouldn't work because of this. Think twice before deciding something.
20.05.22 08:57:44 am
Up
apex2d
User
Offline Off
there's a workaround for Chinese Characters i think, i forgot how tho
Eat Sleep Conquer Repeat. www.Radeon2D.forumid.net
21.05.22 07:50:47 am
Up
UrNightmare
User
Offline Off
Oh yeah and also there's people also workaround to make utf-8 support on Lua 5.1, i found this in Github tho. You can just import it and then wait for the module script to convert it.
26.05.22 04:36:50 pm
Up
MikuAuahDark
User
Offline Off
I think CS2D staying at 5.1 is the best thing DC ever did because I develop a code injection that replaces CS2D stock Lua 5.1 with more powerful LuaJIT (see signature) and if CS2D changes its Lua version, it means my project no longer works because Lua 5.1 and 5.2 is not compatible between each other.

I wrote Lua code optimized for LuaJIT for living and I can say LuaJIT is all what you need to extend your server capabilities beyond what CS2D offer.
file cs2d LuaJIT for Dedicated Server (13) JIT POWER! | Know your Lua errors! | Part of LÖVE development team since 11.3
To the start Previous 1 Next To the start